A fix has been deployed by Intouch. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 14, 2025 - 12:43 UTC
Update
We are still experiencing instabilities in our Intouch MTN deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Apr 14, 2025 - 11:15 UTC
Update
We are still experiencing degraded performance in our Intouch MTN deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Apr 13, 2025 - 21:22 UTC
Update
We are still experiencing degraded performance in our Intouch MTN deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Apr 13, 2025 - 09:49 UTC
Update
We are still experiencing degraded performance in our Intouch MTN deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Apr 12, 2025 - 21:34 UTC
Update
We are still experiencing degraded performance in our Intouch deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Apr 12, 2025 - 18:53 UTC
Update
We are continuing to work on a fix for this issue.
Posted Apr 12, 2025 - 13:39 UTC
Identified
We have identified instability in Cameroon MTN Intouch services. We have escalated this to the MMO for resolution.
Posted Apr 12, 2025 - 09:42 UTC
This incident affected: Cameroon MMO services (MTN :: Web Deposit, MTN :: Payout).