Performance degradation affecting Nigeria PalmPay services

Incident Report for PawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Aug 30, 2025 - 04:03 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Aug 29, 2025 - 23:44 UTC

Investigating

We are experiencing an outage of the Nigeria PalmPay services. We are investigating the issue.
Posted Aug 29, 2025 - 21:08 UTC
This incident affected: Nigeria MMO services (PalmPay :: Web Deposit, PalmPay :: Payout).