Performance degradation affecting Lesotho M-Pesa services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted 18 days ago. Mar 17, 2025 - 01:46 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted 18 days ago. Mar 16, 2025 - 23:18 UTC

Identified

We have identified instability in Lesotho M-Pesa services. We have escalated this to the MMO for resolution.
Posted 19 days ago. Mar 16, 2025 - 16:14 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).