Performance degradation affecting Zambia MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 00:21 UTC

Monitoring

A fix has been deployed by Zambia MTN. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 22, 2025 - 23:58 UTC

Investigating

We are experiencing an outage of the Zambia MTN services. We are investigating the issue.
Posted Apr 22, 2025 - 22:51 UTC
This incident affected: Zambia MMO services (MTN :: Web Deposit, MTN :: Payout).