Performance degradation affecting Cameroon MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 16:41 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 17, 2025 - 15:04 UTC

Investigating

We are experiencing an outage of the Cameroon MTN services. We are investigating the issue.
Posted Mar 17, 2025 - 08:10 UTC
This incident affected: Cameroon MMO services (MTN :: Web Deposit, MTN :: Payout).