Benin MTN scheduled maintenance

Scheduled for Oct 4, 20:30 UTC  -  Oct 5, 05:00 UTC

Update

Benin MTN will be performing maintenance and upgrades during the maintenance window on 04.10 to 05.10 between 20:30 UTC and 05:00 UTC.
Degraded performance and outages are expected.
Posted Sep 24, 2026 - 08:19 UTC

Scheduled

Benin MTN will be performing maintenance and upgrades during the maintenance window on 04.10 to 05.10 between 20:30 UTC and 05:00 UTC.
Degraded performance and outages are expected.
Posted Sep 24, 2026 - 08:19 UTC
This scheduled maintenance affects: Benin MMO services (MTN :: Web Deposit, MTN :: Payout, MTN :: Betting :: Web Deposit, MTN :: Betting :: Payout).