The incident has been resolved. We apologise for the inconvenience.
Posted Jun 12, 2025 - 20:59 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 12, 2025 - 20:03 UTC
Update
We have identified instability in Airtel DRC, Gabon, Malawi, Rwanda, Tanzania, Uganda and Zambia services. We have escalated this to the MMO's for resolution.
Posted Jun 12, 2025 - 18:57 UTC
Identified
We have identified instability in Airtel DRC, Malawi, Rwanda, Tanzania, Uganda and Zambia services. We have escalated this to the MMO's for resolution.
Posted Jun 12, 2025 - 18:26 UTC
This incident affected: Zambia MMO services (Airtel :: Web Deposit, Airtel :: Payout), Rwanda MMO services (Airtel :: Web Deposit, Airtel :: Payout), Uganda MMO services (Airtel :: Web Deposit, Airtel :: Payout), Malawi MMO services (Airtel :: Web Deposit, Airtel :: Payout), Tanzania MMO services (Airtel :: Web Deposit, Airtel :: Payout), DRC MMO services (Airtel :: Web Deposit, Airtel :: Payout), and Gabon MMO services (Airtel :: Payout, Airtel :: Web Deposit).