Performance degradation affecting Tanzania Airtel services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 28, 2024 - 19:02 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 28, 2024 - 18:17 UTC
Identified
We have identified instability in Tanzania Airtel services. We have escalated this to the MMO for resolution.
Posted Nov 28, 2024 - 17:43 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).