Performance degradation affecting Nigeria MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Nov 23, 2024 - 20:51 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 23, 2024 - 20:15 UTC
Investigating
We are experiencing an outage of the Nigeria MTN services. We are investigating the issue.
Posted Nov 23, 2024 - 19:42 UTC
This incident affected: Nigeria MMO services (MTN :: Web Deposit, MTN :: Payout).