Performance degradation affecting Ghana Telecel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 12:46 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 14, 2025 - 12:06 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 14, 2025 - 12:06 UTC

Update

We are continuing to work on a fix for this issue.
Posted Mar 14, 2025 - 10:47 UTC

Update

We are now experiencing an outage in our Ghana Telecel deposit and payout gateways, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Mar 14, 2025 - 09:58 UTC

Identified

This is a quick update to inform you that we are now experiencing degraded performance in our Ghana Telecel deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Mar 14, 2025 - 08:02 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 14, 2025 - 06:53 UTC

Update

Unfortunately we are still experiencing an outage in our Ghana Telecel deposit and payout gateways. Telecel is still working on restoring their services but have not given us an ETA for a resolution. We'll provide an update as soon as possible. Thank you for your patience.
Posted Mar 14, 2025 - 06:15 UTC

Identified

We have identified instability in Ghana Telecel services. We have escalated this to the MMO for resolution.
Posted Mar 13, 2025 - 18:56 UTC
This incident affected: Ghana MMO services (Telecel :: Web Deposit, Telecel :: Payout).