Performance degradation affecting Lesotho M-Pesa services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 21, 2025 - 05:06 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 21, 2025 - 04:02 UTC

Update

This is a quick update to inform you that we are still experiencing an outage in our Lesotho payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Mar 20, 2025 - 21:51 UTC

Identified

We have identified instability in Lesotho M-Pesa services. We have escalated this to the MMO for resolution.
Posted Mar 20, 2025 - 10:50 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).