Performance degradation affecting Kenya M-Pesa services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 21:30 UTC
Monitoring
A fix has been deployed by Kenya M-Pesa. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 26, 2024 - 19:29 UTC
Update
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Nov 26, 2024 - 17:34 UTC
Update
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Nov 26, 2024 - 17:14 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 26, 2024 - 14:03 UTC
Identified
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Nov 26, 2024 - 13:44 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 26, 2024 - 13:18 UTC
Identified
We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Nov 26, 2024 - 12:26 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).