Performance degradation affecting Tanzania Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 29, 2025 - 21:34 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 29, 2025 - 20:07 UTC

Investigating

We are experiencing degraded performance in the Tanzania Airtel services. We are investigating the issue.
Posted Mar 29, 2025 - 17:22 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit, Airtel :: Payout).