Performance degradation affecting Ghana MTN services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Nov 24, 2024 - 17:37 UTC
Monitoring
A fix has been deployed by Ghana MTN. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 24, 2024 - 15:04 UTC
Identified
We have identified instability in Ghana MTN services. We have escalated this to the MMO for resolution.
Posted Nov 24, 2024 - 13:32 UTC
This incident affected: Ghana MMO services (MTN :: Web Deposit, MTN :: Payout).