Performance degradation affecting Tanzania Halotel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Aug 16, 2025 - 20:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 16, 2025 - 19:46 UTC

Identified

This is a quick update to inform you that we are now experiencing degraded performance in our Halotel deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Aug 16, 2025 - 17:42 UTC

Investigating

We are experiencing an outage of the Tanzania Halotel services. We are investigating the issue.
Posted Aug 16, 2025 - 17:02 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).