Performance degradation affecting Cameroon Orange services

Incident Report for PawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 17, 2026 - 15:43 UTC

Identified

We are experiencing degradation in callback delivery by the MMO and as a result, some transactions take longer to be finalized. We are in constant communication with the MMO in order to identify the root cause and stabilize the service as soon as possible. Further updates will be shared once there has been progress made.
Posted Mar 16, 2026 - 08:24 UTC
This incident affected: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout, Orange :: Betting :: Web Deposit, Orange :: Betting :: Payout).