Performance degradation affecting Uganda Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 24, 2025 - 00:53 UTC

Monitoring

A fix has been deployed by Uganda Airtel. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 23, 2025 - 23:48 UTC

Investigating

We are experiencing an outage of the Uganda Airtel services. We are investigating the issue.
Posted Apr 23, 2025 - 22:03 UTC
This incident affected: Uganda MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).