Performance degradation affecting Kenya M-Pesa services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Jun 09, 2026 - 10:59 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 09, 2026 - 07:58 UTC

Identified

This is a quick update to inform you that we are still experiencing degraded performance in our Kenya M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jun 09, 2026 - 07:13 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 09, 2026 - 06:48 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in our Kenya M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jun 09, 2026 - 00:02 UTC

Identified

Kenya M-Pesa is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jun 08, 2026 - 23:20 UTC

Investigating

We are experiencing an outage of the Kenya M-Pesa services. We are investigating the issue.
Posted Jun 08, 2026 - 22:18 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).