Performance degradation affecting Tanzania Yas services

Incident Report for PawaPay

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 01:42 UTC

Update

This is a quick update to inform you that we are still experiencing degraded performance in our Yas deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Dec 03, 2025 - 22:46 UTC

Update

We have identified instability in Tanzania Yas services. We have escalated this to the MMO for resolution.
Posted Dec 03, 2025 - 16:09 UTC

Identified

This is a quick update to inform you that we are still experiencing degraded performance in our Yas deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Dec 03, 2025 - 14:12 UTC

Update

We are continuing to investigate this issue.
Posted Dec 03, 2025 - 05:35 UTC

Investigating

We are experiencing degraded performance in the Tanzania Yas services. We are investigating the issue.
Posted Dec 03, 2025 - 04:35 UTC
This incident affected: Tanzania MMO services (Yas :: Web Deposit, Yas :: USSD Deposit, Yas :: Payout).