Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Apr 01, 2025 - 20:59 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Apr 01, 2025 - 03:39 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Mar 31, 2025 - 17:45 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Mar 31, 2025 - 04:02 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Mar 30, 2025 - 14:45 UTC
Update
We are experiencing an outage in our Orange Cameroon deposit and payout gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Mar 30, 2025 - 14:19 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Mar 30, 2025 - 06:31 UTC
Update
Cameroon Orange Intouch is still experiencing a service instability on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Mar 29, 2025 - 09:59 UTC
Identified
We have identified instability in Cameroon Orange Intouch services. We have escalated this to the MMO for resolution.
Posted Mar 28, 2025 - 16:34 UTC
This incident affects: Cameroon MMO services (Orange :: Web Deposit, Orange :: Payout).