Performance degradation affecting Kenya M-Pesa services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 18, 2025 - 15:57 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 18, 2025 - 14:01 UTC

Investigating

We are experiencing degraded performance in the Kenya M-Pesa services. We are investigating the issue.
Posted Apr 18, 2025 - 13:26 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit).