Performance degradation affecting NFS Zambia Zamtel services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Jun 19, 2025 - 12:46 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 19, 2025 - 12:07 UTC

Update

The issue has been identified and a fix is being implemented.
Posted Jun 19, 2025 - 08:50 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2025 - 22:40 UTC

Update

We are experiencing an outage of the Zambia Zamtel services.
Posted Jun 18, 2025 - 20:09 UTC

Update

We are experiencing an outage of the NFS Zambia Zamtel services.
Posted Jun 18, 2025 - 18:39 UTC

Investigating

We are experiencing an outage of the NFS Zambia Zamtel services. We are investigating the issue.
Posted Jun 18, 2025 - 18:30 UTC
This incident affected: Zambia MMO services (Zamtel :: Web Deposit, Zamtel :: Payout, Zamtel :: USSD Deposit).