A fix has been deployed by MTN. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Dec 18, 2025 - 10:23 UTC
Update
MTN is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Dec 18, 2025 - 08:19 UTC
Identified
MTN is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Dec 18, 2025 - 06:58 UTC
Investigating
We are experiencing degraded performance in the Cameroon, Congo, Ghana, Nigeria, Zambia MTN services. We are investigating the issue.
Posted Dec 18, 2025 - 05:37 UTC
This incident affected: Cameroon MMO services (MTN :: Web Deposit, MTN :: Payout), Benin MMO services (Celtiis :: Web Deposit, Celtiis :: Payout, Moov :: Web Deposit, Moov :: Payout, MTN :: Web Deposit, MTN :: Payout), Ghana MMO services (MTN :: Web Deposit, MTN :: Payout), Nigeria MMO services (MTN :: Web Deposit, MTN :: Payout), Congo Brazzaville MMO Services (MTN :: Payout, MTN :: Web Deposit), and Zambia MMO services (MTN :: Web Deposit, MTN :: Payout).