Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 29, 2024 - 22:16 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 29, 2024 - 20:55 UTC
Investigating
We are experiencing degraded performance in the Tanzania Halotel services. We are investigating the issue.
Posted Nov 29, 2024 - 16:51 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit).