Performance degradation affecting Zambia Zamtel services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 13, 2025 - 21:35 UTC

Update

We are still experiencing an outage in our Zamtel Zambia NFS payout gateway. We'll provide an update as soon as possible. Thank you for your patience.
Posted Mar 13, 2025 - 21:04 UTC

Identified

We have identified instability in Zambia Zamtel services. We have escalated this to the MNO for resolution.
Posted Mar 13, 2025 - 20:23 UTC
This incident affected: Zambia MMO services (Zamtel :: Web Deposit, Zamtel :: Payout, Zamtel :: USSD Deposit).