The incident has been resolved. We apologise for the inconvenience.
Posted Jun 11, 2025 - 22:26 UTC
Monitoring
A fix has been deployed by Uganda MTN. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 11, 2025 - 19:36 UTC
Update
We are still experiencing service disruption in our Uganda MTN services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Jun 11, 2025 - 18:24 UTC
Identified
We are still experiencing service disruption in our Uganda MTN services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible. Thank you for your patience.
Posted Jun 11, 2025 - 16:18 UTC
Investigating
We are experiencing an outage in the Uganda MTN services. We are investigating the issue.
Posted Jun 11, 2025 - 14:51 UTC
This incident affected: Uganda MMO services (MTN :: Web Deposit, MTN :: USSD Deposit, MTN :: Payout).