Maintenance has been completed. We are verifying full MMO service availability.
Posted Apr 22, 2025 - 03:53 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 21, 2025 - 20:00 UTC
Update
Zambia MTN will be performing maintenance and upgrades during the maintenance window on 21.04 to 22.04 between 22:00 UTC and 05:00 UTC. Degraded performance and outages are expected.
Posted Apr 21, 2025 - 17:16 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Apr 21, 2025 - 17:14 UTC
Scheduled
Zambia MTN will be performing maintenance and upgrades during the maintenance window on 21.04 to 22.04 between 22:00 UTC and 05:00 UTC. Degraded performance and outages are expected.
Posted Apr 21, 2025 - 17:13 UTC
This scheduled maintenance affected: Zambia MMO services (MTN :: Web Deposit, MTN :: Payout).