Performance degradation affecting Tanzania Yas services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 16, 2025 - 08:38 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 16, 2025 - 08:11 UTC

Identified

We have identified instability in Tanzania Yas services. We have escalated this to the MMO for resolution.
Posted Mar 16, 2025 - 07:34 UTC
This incident affected: Tanzania MMO services (Yas :: Web Deposit).