Performance degradation affecting Tanzania Halotel services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 28, 2025 - 05:33 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 28, 2025 - 04:46 UTC

Identified

We have identified instability in Tanzania Halotel services. We have escalated this to the MMO for resolution.
Posted Mar 27, 2025 - 21:26 UTC
This incident affected: Tanzania MMO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).