Performance degradation affecting Lesotho M-Pesa services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 12:45 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 14, 2025 - 11:44 UTC

Investigating

We are experiencing an outage of the Lesotho M-Pesa services. We are investigating the issue.
Posted Mar 14, 2025 - 09:59 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).