Performance degradation affecting Airtel DRC, Malawi, Zambia, Rwanda, Tanzania, Gabon, Uganda MMO services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Jun 21, 2025 - 15:10 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jun 21, 2025 - 13:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 21, 2025 - 11:55 UTC

Identified

We have identified instability in Airtel DRC, Malawi, Zambia, Rwanda, Tanzania, Gabon, Uganda. We have escalated this to the MMO for resolution.
Posted Jun 21, 2025 - 11:48 UTC
This incident affected: Zambia MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout), Rwanda MMO services (Airtel :: Web Deposit, Airtel :: Payout), Uganda MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout), Malawi MMO services (Airtel :: Web Deposit, Airtel :: Payout), Tanzania MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout), DRC MMO services (Airtel :: Web Deposit, Airtel :: Payout), Gabon MMO services (Airtel :: Payout, Airtel :: Web Deposit), and Congo Brazzaville MMO Services (Airtel :: Payout, Airtel :: Web Deposit).