Performance degradation affecting Tanzania Tigopesa services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 10, 2024 - 18:11 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Oct 10, 2024 - 16:57 UTC
Identified
We have identified instability in Tanzania Tigopesa services. We have escalated this to the MNO for resolution.
Posted Oct 10, 2024 - 15:20 UTC
This incident affected: Tanzania MNO services (Tigopesa :: Web Deposit).