Performance degradation affecting Uganda Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted 17 days ago. Mar 17, 2025 - 13:44 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted 17 days ago. Mar 17, 2025 - 12:51 UTC

Update

We are continuing to work on a fix for this issue.
Posted 17 days ago. Mar 17, 2025 - 09:06 UTC

Identified

We have identified instability in Uganda Airtel services. We have escalated this to the MMO for resolution.
Posted 17 days ago. Mar 17, 2025 - 08:29 UTC
This incident affected: Uganda MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).