Performance degradation affecting Uganda MTN services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Apr 25, 2025 - 01:01 UTC

Investigating

We are experiencing degraded performance in the Uganda MTN services. We are investigating the issue.
Posted Apr 24, 2025 - 22:06 UTC
This incident affected: Uganda MMO services (MTN :: Web Deposit, MTN :: USSD Deposit, MTN :: Payout).