Performance degradation affecting Kenya M-Pesa MMO services

Incident Report for pawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Mar 26, 2025 - 18:02 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 26, 2025 - 17:39 UTC

Identified

We have identified instability in Kenya M-Pesa services. We have escalated this to the MMO for resolution.
Posted Mar 26, 2025 - 16:55 UTC
This incident affected: Kenya MMO services (M-Pesa :: Web Deposit, M-Pesa :: USSD Deposit, M-Pesa :: Payout).