Performance degradation affecting Tanzania Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 03:44 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2025 - 02:39 UTC

Identified

This is a quick update to inform you that we are experiencing an outage in Tanzania Airtel services, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Apr 12, 2025 - 23:33 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 12, 2025 - 23:12 UTC

Identified

We have identified instability in Tanzania Airtel services. We have escalated this to the MMO for resolution.
Posted Apr 12, 2025 - 23:00 UTC
This incident affected: Tanzania MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).