Performance degradation affecting Uganda Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 07:15 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2025 - 05:48 UTC

Investigating

We are experiencing an outage of the Uganda Airtel services. We are investigating the issue.
Posted Nov 14, 2025 - 04:53 UTC
This incident affected: Uganda MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).