Performance degradation affecting Zambia MTN services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 20:56 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Apr 01, 2025 - 18:26 UTC

Identified

We have identified instability in Zambia MTN services. We have escalated this to the MNO for resolution.
Posted Apr 01, 2025 - 16:18 UTC
This incident affected: Zambia MMO services (MTN :: Payout).