Performance degradation affecting Nigeria Airtel services

Incident Report for PawaPay

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Jul 18, 2026 - 04:25 UTC

Update

Airtel Nigeria is still facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jul 17, 2026 - 23:49 UTC

Identified

Airtel Nigeria is facing an outage on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jul 17, 2026 - 23:39 UTC

Investigating

We are experiencing degraded performance in the Nigeria Airtel services. We are investigating the issue.
Posted Jul 17, 2026 - 22:23 UTC
This incident affects: Nigeria MMO services (Airtel :: Web Deposit, Airtel :: Payout).