We are seeing improvements in success rates and will continue monitoring the incident.
Posted May 16, 2025 - 10:09 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 16, 2025 - 04:30 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 15, 2025 - 04:47 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 14, 2025 - 03:15 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 13, 2025 - 03:42 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 12, 2025 - 07:48 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 11, 2025 - 21:02 UTC
Identified
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted May 11, 2025 - 18:26 UTC
Investigating
We are experiencing degraded performance in the Lesotho M-Pesa services. We are investigating the issue.
Posted May 11, 2025 - 12:08 UTC
This incident affected: Lesotho MMO services (M-Pesa :: Web Deposit, M-Pesa :: Payout).