Performance degradation affecting Uganda MTN services
Incident Report for pawaPay
Resolved
The incident has been resolved. We apologise for the inconvenience.
Posted Nov 28, 2024 - 09:32 UTC
Monitoring
We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 28, 2024 - 06:11 UTC
Identified
We have identified instability in Uganda MTN services. We have escalated this to the MMO for resolution.
Posted Nov 28, 2024 - 05:23 UTC
This incident affected: Uganda MMO services (MTN :: Web Deposit, MTN :: USSD Deposit, MTN :: Payout).