Zambia Zamtel scheduled maintenance

Incident Report for PawaPay

Resolved

All MMO services verified to be operational.
Posted Jun 07, 2026 - 22:41 UTC

Update

All MMO services verified to be operational.
Posted Jun 07, 2026 - 22:38 UTC

Update

Maintenance has been completed. We are verifying full MMO service availability.
Posted Jun 07, 2026 - 21:58 UTC

Investigating

Scheduled maintenance has started. We will provide updates as necessary.
Posted Jun 07, 2026 - 21:12 UTC
This incident affected: Zambia MMO services (NFS :: Zamtel :: Payout, Zamtel :: Web Deposit, Zamtel :: Payout, Zamtel :: USSD Deposit).