M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 05, 2025 - 05:50 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 04, 2025 - 05:17 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 03, 2025 - 20:28 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 03, 2025 - 04:02 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 02, 2025 - 19:42 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 02, 2025 - 03:28 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Feb 01, 2025 - 12:03 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 31, 2025 - 20:55 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 31, 2025 - 06:43 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 30, 2025 - 09:10 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 29, 2025 - 10:39 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 29, 2025 - 05:11 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 28, 2025 - 12:50 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 28, 2025 - 06:55 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 27, 2025 - 16:45 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 27, 2025 - 05:55 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 26, 2025 - 10:50 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 25, 2025 - 04:12 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 24, 2025 - 05:19 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 23, 2025 - 13:43 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 23, 2025 - 06:17 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 23, 2025 - 00:10 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 22, 2025 - 02:40 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 21, 2025 - 05:28 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 20, 2025 - 11:33 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 19, 2025 - 09:04 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 18, 2025 - 09:27 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 17, 2025 - 11:42 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 17, 2025 - 05:49 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 16, 2025 - 11:05 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 15, 2025 - 05:01 UTC
Update
M-Pesa Lesotho is still facing degraded performance on their platform and they have not provided any ETA for a resolution. We will share an update in case of any improvements. Thank you for your patience and understanding.
Posted Jan 14, 2025 - 08:33 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 13, 2025 - 17:09 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 13, 2025 - 07:32 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 12, 2025 - 17:06 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 12, 2025 - 05:13 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 11, 2025 - 19:40 UTC
Update
We are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 11, 2025 - 07:04 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 10, 2025 - 20:15 UTC
Update
This is a quick update to inform you that we are still experiencing degraded performance in our Lesotho M-Pesa deposit gateway, but are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Jan 10, 2025 - 12:40 UTC
Identified
We have identified instability in Lesotho M-Pesa services. We have escalated this to the MMO for resolution.
Posted Jan 10, 2025 - 04:46 UTC
This incident affects: Lesotho MMO services (M-Pesa :: Web Deposit).