Performance degradation affecting Tanzania Tigopesa services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 11, 2024 - 20:05 UTC
Investigating
We are experiencing an outage of the Tanzania Tigopesa services. We are investigating the issue.
Posted Oct 11, 2024 - 18:19 UTC
This incident affected: Tanzania MNO services (Tigopesa :: Web Deposit, Tigopesa :: USSD Deposit, Tigopesa :: Payout).