Performance degradation affecting Tanzania Halotel services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Oct 12, 2024 - 23:25 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 12, 2024 - 20:38 UTC
Investigating
We are experiencing degraded performance in the Tanzania Halotel services. We are investigating the issue.
Posted Oct 12, 2024 - 18:25 UTC
This incident affected: Tanzania MNO services (Halotel :: Web Deposit, Halotel :: USSD Deposit, Halotel :: Payout).