Performance degradation affecting Tanzania Tigopesa MMO services
Incident Report for pawaPay
Resolved
This incident has been resolved.
Posted Nov 24, 2024 - 13:31 UTC
Monitoring
A fix has been deployed by Tanzania Tigopesa. We are seeing improvements in success rates and will continue monitoring the incident.
Posted Nov 24, 2024 - 11:32 UTC
Identified
We have identified instability in Tanzania Tigopesa services. We have escalated this to the MMO for resolution.
Posted Nov 24, 2024 - 10:52 UTC
This incident affected: Tanzania MMO services (Tigopesa :: Web Deposit, Tigopesa :: USSD Deposit, Tigopesa :: Payout).