This is a quick update to inform you that we are still experiencing an outage in our Kenya Airtel payout gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Apr 04, 2025 - 09:41 UTC
Update
This is a quick update to inform you that we are still experiencing an outage in our Kenya Airtel payout gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Apr 03, 2025 - 19:09 UTC
Update
This is a quick update to inform you that we are still experiencing an outage in our Kenya Airtel payout gateway, but we are closely following up on it with the mobile money operator. We'll provide an update as soon as possible.
Posted Apr 03, 2025 - 04:19 UTC
Identified
We have identified instability in Kenya Airtel services. We have escalated this to the MMO for resolution.
Posted Apr 02, 2025 - 19:15 UTC
This incident affects: Kenya MMO services (Airtel :: Payout).