Performance degradation affecting Rwanda Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted Mar 18, 2025 - 04:42 UTC

Monitoring

We are seeing improvements in success rates and will continue monitoring the incident.
Posted Mar 18, 2025 - 00:47 UTC

Investigating

We are experiencing an outage of the Rwanda Airtel services. We are investigating the issue.
Posted Mar 17, 2025 - 23:53 UTC
This incident affected: Rwanda MMO services (Airtel :: Web Deposit, Airtel :: Payout).