Performance degradation affecting Uganda Airtel services

Incident Report for pawaPay

Resolved

This incident has been resolved.
Posted May 13, 2025 - 20:46 UTC

Update

We are continuing to investigate this issue.
Posted May 13, 2025 - 18:16 UTC

Investigating

We are experiencing degraded performance in the Uganda Airtel services. We are investigating the issue.
Posted May 13, 2025 - 16:50 UTC
This incident affected: Uganda MMO services (Airtel :: Web Deposit, Airtel :: USSD Deposit, Airtel :: Payout).