Performance degradation affecting Benin MTN services

Incident Report for PawaPay

Resolved

The incident has been resolved. We apologise for the inconvenience.
Posted Feb 16, 2026 - 07:22 UTC

Update

We are experiencing an outage of the Benin MTN services. We are investigating the issue.
Posted Feb 15, 2026 - 22:59 UTC

Investigating

We are experiencing an outage of the Benin MTN services. We are investigating the issue.
Posted Feb 15, 2026 - 22:57 UTC
This incident affected: Benin MMO services (MTN :: Payout).